Según OWC, con Unsupported UtilityX los usuarios de determinados modelos de máquinas antiguas pueden instalar Mac OS X o Mac OS X Server desde el CD original de Apple. En los siguientes modelos se pueden instalar y utilizar los nuevos sistemas operativos de Apple, según el desarrollador: Power Macintosh 7300, 7500, 7600, 8500, 8600, 9500, 9600 y determinados clónicos de Apple como Umax S900 y J700; y los modelos de Power Computing; PowerWave y PowerTowerPro.

Unsupported UtilityX 2.0 funciona con la versión Mac OS X 10.1, pero también con las versiones anteriores del sistema (10.0.x), según afirma el desarrollador. La aplicación puede ser descargada desde la dirección: http://eshop.macsales.com/OSXCenter/