Apple actualiza su sistema operativo de escritorio macOS (anteriormente Mac OS X) una vez al año, como un reloj, con el que aporta nuevas características y mejoras. Eso está muy bien, pero la versión más reciente conocida como Big Sur, no correrá en ningún Mac anterior a 2013. 

Es más, en algunos casos, ni tan siquiera en modelos de 2014. Esto puede significar que tu Mac no puede actualizarse oficialmente, a menos que sigas un tutorial paso a paso como el que te ofrecemos a continuación.

Antes de continuar y seguir con los consejos, una advertencia: hay una razón por la que Apple elige no admitir el nuevo sistema operativo Mac en equipos más antiguos. Los Mac más antiguos no tienen los componentes necesarios o la potencia para hacer frente a la demanda del sistema.

Entonces, si instalo Big Sur, Catalina o cualquier versión reciente de macOS en un Mac no compatible, no esperes que pueda funcionar más rápido, puesto que puede que hagan su aparición ciertos problemas. 

¿Es demasiado viejo mi Mac para actualizar?

Tenemos una guía sobre qué Macs y MacBooks son compatibles con macOS Big Sur con una lista completa de todos los modelos que oficialmente y según Apple pueden ejecutar la última versión de macOS. 

A continuación, te ofrecemos una descripción general de los Mac que ejecutan Big Sur: 

  • Modelos de MacBook de principios de 2015 o posteriores
  • Modelos de MacBook Air de 2013 o posteriores
  • Modelos de MacBook Pro de 2013 o posteriores
  • Modelos de Mac mini de 2014 o posteriores
  • Modelos de iMac de 2014 o posteriores
  • iMac Pro (todos los modelos)
  • Modelos de Mac Pro de 2013 o posteriores

Apple informa que macOS Catalina se ejecutará en los siguientes Mac:

  • Modelos de MacBook de principios de 2015 o posteriores
  • Modelos de MacBook Air de mediados de 2012 o posteriores
  • Modelos de MacBook Pro de mediados de 2012 o posteriores
  • Modelos de Mac mini de finales de 2012 o posteriores
  • Modelos de iMac de finales de 2012 o posteriores
  • iMac Pro (todos los modelos)
  • Modelos de Mac Pro de finales de 2013

Apple informa que macOS Mojave se ejecuta en los siguientes Mac:

  • Modelos de Mac de 2012 o posteriores
  • iMac Pro (desde 2017)
  • Modelos de MacBook de 2015 o posteriores
  • Modelos de MacBook Pro de 2012 o posteriores
  • Modelos de MacBook Air de 2012 o posteriores
  • Modelos de Mac mini de 2012 o posteriores
  • Modelos de Mac Pro de finales de 2013 (más modelos de mediados de 2010 y mediados de 2012 con GPU con capacidad Metal recomendada)

La versión de macOS High Sierra más antiguo tenía un poco más de alcance. Apple dijo que funcionaría en un MacBook o iMac de finales de 2009 o posterior, o en un MacBook Air, MacBook Pro, Mac mini o Mac Pro de 2010 o posterior. 

Esto significa que si tu Mac es anterior a 2012, oficialmente no podrás ejecutar Catalina o Mojave en tu equipo. En el caso de Catalina se incluye todos los modelos de Mac Pro de estilo antiguo, por llamarlo de alguna manera. 

A pesar de todo esto, es posible ejecutar versiones más recientes de macOS en Mac más antiguas gracias a un parche, sin estar oficialmente aprobado por Apple, claro está. Así, por ejemplo, muchos Mac antiguos presentan problemas con la wifi tras instalar macOS Big Sur. 

La ejecución de Big Sur en un Mac no compatible también puede considerarse que va contra los términos y condiciones de Apple de cara a recibir soporte técnico. 

Cómo instalar macOS Big Sur en un Mac no compatible

Si tu Mac tiene más de unos años e intentas instalar Big Sur, encontrarás algunos obstáculos, el primero de los cuales es el hecho de que el sistema no te ofrecerá la nueva versión de macOS para su instalación. 

Si accedes a GitHub, podrás encontrar el denominado big-sur-micropatcher que puedes descargarte para instalar macOS Big Sur en tu Mac antiguo. En la página, encontrarás algunas notas que indican las diferentes fechas de su creación. Revisa todas las notas de compatibilidad. 

El procedimiento para actualizar a una nueva versión de macOS en Mac incompatibles es el siguiente: 

  1. En primer lugar, deberás obtener los archivos de instalación para el sistema operativo. Tendrás que obtenerlos con un Mac compatible. Si no aparecen en ‘Actualización de software’, buscalos en la Mac App Store .
  2. Ahora debes cargar estos archivos de instalación en una memoria USB y preparar la memoria USB para instalar macOS Big Sur. Explicamos cómo crear un USB de arranque de macOS en un artículo separado. 
  3. A continuación, debes obtener un software que pueda engañar a los archivos de instalación de la versión de macOS que deseas instalar para que crean que Mac es compatible. Puedes descargar ese parche que mencionamos anteriormente desde GitHub. Haz clic en los botones ‘Código y Descargar Zip’.
  4. Después de extraer el archivo de la descarga, encontrarás el archivo "micropatcher.sh".
  5. Abre una ventana de Terminal y arrastra y suelta el archivo en la ventana. Luego ejecuta el comando.
  6. Ahora instala macOS desde tu unidad o disco instalador de arranque.
  7. En algunos casos, aún quedan tareas por realizar después de la instalación. Estas se pueden encontrar en las instrucciones de big-sur-micropatcher. Después de preparar el Mac con la memoria USB, inicia una terminal e ingresa ‘/ Volumes / Image \ Volume / set-vars.sh’. El script es parte del parche para macOS Big Sur y modifica configuraciones importantes para el arranque y los archivos del sistema. 

macOS Big Sur terminal code

Debes saber que la instalación puede demorar hasta horas. En nuestro caso, parecía que el instalador se había bloqueado durante la actualización. Deberás tener paciencia. Con el paso del tiempo, aparecerán nuevas formas, pero actualmente, es el enfoque más seguro que hay. 

Cómo instalar actualizaciones de Big Sur en un Mac no compatible

Una vez que haya instalado macOS Big Sur, las actualizaciones aparecerán en ‘Actualizaciones de software’ tan pronto como estén disponibles. Sin embargo, no deberías instalarlas, ya que lo ideal será volver a crear una memoria USB con los archivos de instalación actuales. 

Cómo ejecutar Catalina en un Mac antiguo

Puedes descargar macOS Catalina Patcher de un desarrollador conocido como s DOSDude1. El parche te permitirá instalar Catalina en un Mac más antiguo que según el soporte de Apple se ha quedado fuera de la lista de compatibilidad. 

El truco de Catalina no funciona con todos los Mac, pero muchos están cubiertos. Puedes ver si tu Mac es compatible con este comparador de la web.

DODDude1 ofrece un vídeo tutorial para facilitar las cosas. Hemos simplificado los pasos y te los indicamos a continuación: 

  1. Descarga la última versión del parche de Catalina. (Puedes hacer una donación).
  2. Abre la aplicación Catalina Patcher.
  3. Haz clic en ‘Continuar’.
  4. Elige ‘Descargar una copia’.
  5. La descarga (de Catalina) comenzará, ya que ocupa casi 8 GB.
  6. Conecta una unidad USB flash.
  7. Elige 'Crear un disco de arranque' entre las opciones.
  8. Conecta el instalador de arranque en el Mac que deseas actualizar.
  9. Reinicia el Mac mientras mantienes presionada la tecla ‘Opción / Alt’. Esto hará que el Mac se abra en el ‘Administrador de inicio’.
  10. Elige la unidad de instalación de arranque y pulsa Intro.
  11. Ahora tu Mac debería abrirse en modo ‘Recuperación’.
  12. Elige ‘Reinstalar macOS’ y espera a que se instale la nueva versión de macOS.
  13. Una vez completada la instalación, deberás reiniciar el Mac en modo de recuperación nuevamente, eligiendo la unidad que contiene el instalador.
  14. Ahora elige ‘macOS Post Install’ y los parches necesarios se instalarán en tu Mac para que Catalina pueda funcionar.
  15. Cuando se hayan aplicado los parches, elige ‘Forzar reconstrucción de caché’.
  16. Reinicia el equipo.
  17. Cuando se reinicie, tu Mac ahora debería iniciarse con una versión completamente funcional de macOS Catalina.

Si resulta que estás ejecutando una versión de macOS anterior a High Sierra o Mojave, deberás formatear tu disco duro al formato APFS. 

Cómo ejecutar macOS Mojave en un Mac antiguo

Al igual que sucede con Catalina, también existe una herramienta de parche DOSDude1 para poder instalar macOS Mojave en un Mac no compatible. 

Puedes descargar la herramienta Mojave Patch Tool.

Con el parche instalado, puedes remontarte a los primeros modelos de 2008. Es poco probable que funcione a pleno rendimiento, por lo que Apple desaconseja esta acción. Pero deberías poder lograr un rendimiento tolerable para su uso.

Por qué no deberías instalar el nuevo macOS en un viejo Mac

Recomendamos a los más principiantes en tecnología que no intenten esta solución alternativa: requiere un grado moderado de experiencia.

Recuerda que vamos en contra del consejo oficial de Apple en esta ocasión, lo que significa que si algo sale mal, y eso siempre es posible con la instalación de un sistema operativo, incluso si estás utilizando software oficial, es poco probable que tu garantía te salve. 

Por supuesto, es poco probable que tu Mac de 2008 tenga alguna garantía, por lo que es posible que eso no te preocupe en exceso. De cualquier forma, haz una copia de seguridad de tu Mac antes de continuar. 

Ten cuenta dos advertencias más. En algún momento, Apple puede parchear este truco y evitar que funcione en el futuro. Entonces, si estás interesado en hacerlo, deberías proceder con ello y no esperar más adelante. 

Si quieres saber todas las novedades que aporta macOS Big Sur, echa un vistazo a nuestra review de macOS Big Sur donde damos respuesta a la pregunta de si deberías actualizar tu Mac.